Title: IP QoS Principles
1IP QoS Principles
- Theory and Practice
- Dimitrios Kalogeras
2A Bit of History
- The Internet, originally designed for U. S.
government use, offered only one service level
Best Effort. - No guarantees of transit time or delivery
- Rudimentary prioritization was available, but it
was rarely used. - Commercialization began in early 1990s
- Private (intranet) networks using Internet
technology appeared. - Commercial users began paying directly for
Internet use. - Commerce sites tried to attract customers by
using graphics. - Industry used the Internet and intranets for
internal, shared communications that combined
previously-separate, specialized networks -- each
with its own specific technical requirements. - New technologies (voice over the Internet, etc.)
appeared, designed to capitalize on inexpensive
Internet technologies.
3The Demands on Modern Networks
- Network flexibility is becoming central to
enterprise strategy - Rapidly-changing business functions no longer
carried out in stable ways, in unchanging
locations, or for long time-periods - Network-enabled applications often crucial for
meeting new market opportunities, but theres no
time to custom-build a network - Traffic is bursty
- Interactive voice, video applications have
stringent bandwidth and latency demands - Multiple application networks are being combined
into consolidated corporate utility networks - Bandwidth contention as critical transaction
traffic is squeezed by web browsing, file
transfers, or other low-priority or bulk traffic - Latency problems as interactive voice and video
are squeezed by transaction, web browsing, file
transfer, and bulk traffic
4Definitions
- Quality of Service (QoS) classifies network
traffic and then ensures that some of it receives
special handling. - May track each individual dataflow
(senderreceiver) separately. - May include attempts to provide better error
rates, lower network transit time (latency), and
decreased latency variation (jitter). - Differentiated Class of Service (CoS) is a
simpler alternative to QoS. - Doesn't try to distinguish among individual
dataflows instead, uses simpler methods to
classify packets into one of a few categories. - All packets within a particular category are then
handled in the same way, with the same quality
parameters. - Policy-Based Networking provides end-to-end
control. - The rules for access and for management of
network resources are stored as policies and are
managed by a policy server.
5QoS Background
QoS development inspired by new types of
applications in IP environment
- Video Streaming Services
- Video Conferencing
- VoIP
- Legacy SNA / DLSw
6QoS Architecture Models
- Best Effort Service
- Integrated Service
- Differentiated Service
7Best Effort Service
- What exactly IP does
- All packets treated equally
- Unpredictable bandwidth
- Unpredictable delay and jitter
8IntServ (RFC1633)
9DiffServ (RFC2474/2475)
10QoS Architecture Components
- Classification
- Coloring
- Admission Control
- Traffic Shaping/Policing
- Congestion Management
- Congestion Avoidance
- Signaling
11Statistical Behavior Random Arrival
- In random arrival, the time that each packet
arrives is completely independent of the time
that any other packet arrives. - If the true situation is that arrivals tend to be
evenly spaced, then random arrival calculations
will overestimate the queuing delay. - If the true situation is that arrivals are
bunched in groups (typical of data flows, such as
packets and acknowledgements), then random
arrival calculations will underestimate the
queuing delay. - Our intuition is usually misleading when we think
of random processes. - We tend to assume that queue size increases
linearly as the number of customers increases. - But, with random arrival, there is a drastic
increase in queue size as the customer arrival
rate approaches 80 of the theoretical server
capacity. Theres no way to store the capacity
that is unused by late customers, but early
customers increase the queue.
12Random Arrival and Intuition
- The surprising increase in queue length is best
shown by a graph
13Random Arrival vs. Self-Similar
- Although random arrival is very convenient
mathematically (its relatively simple to do
random arrival calculations), it has been shown
that much data traffic is self-similar. - Ethernet and Internet traffic flows, in
particular, are self-similar. - The rate of initial connections is still random,
however. - Self-similar traffic shows the same pattern
regardless of changes in scale. - Fractal geometry (e.g., a coastline) is an
example. - Self-similar traffic has a heavy tail.
- The probabilities of extremely large values
(e.g., file lengths of a gigabyte or more) dont
decrease as rapidly, as they would with random
distributions of file lengths. - This matches real data traffic behaviors.
- Long file downloads mixed with short
acknowledgements - Compressed video with action scenes mixed with
static scenes
14Traffic Classification
- Most fundamental QoS building block
- The component of a QoS feature that recognizes
and distinguishes between different traffic
streams - Without classification, all packets are treated
the same
15Traffic Classification/Admission Control Issues
- Always performed at the network perimeter
- Makes traffic conform to the internal network
policy - Marks packets with special flags (colors)
- Colors used afterwards inside the network for QoS
management
16Classification/Admission Control Scheme
17Classification Criteria
- IP header fields
- TCP/UDP header fields
- Routing information
- Packet Content (NBAR)i.e. HTTP, HTTPS, FTP,
Napster etc.
18Traffic Coloring Options
- IP Precedence
- DSCP
- QoS Group
- 802.1p CoS
- ATM CLP
- Frame Relay DE
19Type-of-Service (RFC791)
Precedence
Unused
D
T
R
Version
Length
Total Length
ToS Field
8
0
15
31
20IP Precedence Values
21DSCPDiffserv Code Point
DSCP (6 bits)
Unused
22Classification mechanisms
- MQC ( Modular Qos Command Line Interface)
- CAR ( Commited Access Rate)
23Modular QoS CLI
- Modular QoS CLI (MQC)
- Command syntax introduced in 12.0(5)T
- Reduces configuration steps and time
- Uniform CLI across all main Cisco IOS-based
platforms - Uniform CLI structure for all QoS features
24Basic MQC Commands
25Basic MQC Commands
- 1. Create Class Map defines traffic selection
criteria
Router(config) class-map class1 Router(config-cma
p) match ip precedence 5 Router(config-cmap)
exit
- 2. Create Policy Map- associates classes with
actions
Router(config) policy-map policy1 Router(config-p
map) class class1 Router(config-pmap-c) set
mpls experimental 5 Router(config-pmap-c)
bandwidth 3000 Router(config-pmap-c)
queue-limit 30 Router(config-pmap) exit
- 3. Attach Service Policy enforces policy to
interfaces
Router(config) interface e1/1 Router(config-if)
service-policy output policy1 Router(config-if)
exit
26Classification Configuring Sample
IOS 12.1(5)T
MQC based
- class-map match-all premium
- match access-group name premium
- !
- class-map match-any trash
- match protocol napster
- match protocol fasttrack
- !
- policy-map classify
- class premium
- set ip precedence priority
- class trash
- police 64000 conform-action set-prec-transmit 1
excess-action drop - !
- ip access-list extended premium
- permit tcp host 10.0.0.1 any eq telnet
- !
- interface serial 2/1
- ip unnumbered loopback 0
- service-policy input classify
Traffic class definitions
QoS policy definition
ACL definition
QoS Policy attachedto interface
27Classification Configuring Sample
CAR based
- ip cef
- !
- interface serial 2/1
- ip unnumbered loopback 0
- rate-limit input access-group 100 64000 8000
8000 conform-action set-prec-transmit 1
exceed-action set-prec-transmit 0 - !
- access-list 100 permit tcp host 10.0.0.1 any eq
http
CAR definition
ACL definition
28Classification Configuring Sample
Route-map based
- route-map classify permit 10
- match ip address 100
- set ip precedence flash
- !
- route-map classify permit 20
- match ip next-hop 1
- set ip precedence priority
- !
- interface serial 2/1
- ip unnumbered loopback 0
- ip policy route-map classify
- !
- access-list 1 permit 192.168.0.1
- access-list 100 permit tcp host 10.0.0.1 any eq
http
Route-map definitions
Route-map attachedto interface
ACL definitions
29Shaping/Policing
- Used to assign more predictive behavior to
traffic - Uses Token Bucket model
30Token Bucket Model
Token Bucket characterizes traffic source
- Token Bucket main parameters
- Token Arrival Rate - v
- Bucket Depth - Bc
- Time Interval tc
- Link Capacity - C
tc Bc/v
31Token Bucket Model
- Bucket is being filled with tokens at a rate v
token/sec. - When bucket is full all the excess tokens are
discarded. - When packet of size L arrives, bucket is checked
for availability of corresponding amount of
tokens. - If several packets arrive back-to-back and there
are sufficient tokens to serve them all, they are
accepted at peak rate (usually physical link
speed). - If enough tokens available, packet is optionally
colored and accepted to the network and
corresponding amount of tokens is subtracted from
the bucket. - If not enough tokens, special action on packet is
performed.
32Token Bucket Model
- Actions performed on nonconforming packets
- Dropped (Policing)
- Delayed in queue either FIFO or WFQ (Shaping)
- Colored/Recolored
33Token Bucket Model
- Bucket depth variation effect
- Bc 0 Constant Bit Rate (CBR)
- Bc?? No Regulation
- Bucket depth is characteristic of traffic
burstiness - Maximum number of bytes transmitted over period
of time ?t - A(?t)max Bcv?t
34Excess Burst (Be)Cisco Implementation
- GTS ( Generic Traffic Shaping)
- If during previous tcn-1 interval bucket Bc was
not depleted (there is no congestion), in the
next interval tcn BcBe bytes are available for
burst. - In frame relay implementations packets admitted
via Be tokens are marked with DE bit.
35Excess Burst (Be)Cisco Implementation
- CBTS (Class Based Traffic Shaping)
- allows higher throughput in uncongested
environment up to peak rate calculated as
vPeak vCIR(1Be/Bc) - Peak rate can be set up manually.
36Excess Burst (Be)Cisco Implementation
- CAR
- allows RED like behavior
- traffic fitting into Bc always conforms
- traffic fitting into Be conforms with probability
proportional to amount of tokens left in the
bucket - traffic not fitting into Be always exceedsCAR
uses the following parameters - ?t time period since the last packet arrival
- Current Debt (Dcur) Amount of debt during
current time interval - Compound Debt (Dcomp) Sum of all Dcur since the
last drop - Actual Debt (Dact) Amount of tokens currently
borrowed
37Excess Burst (Be)Cisco Implementation
Packet of lengthL arrived
CAR Algorithm
ConformAction
Y
Bccur L gt 0
Bccur Bccur L
N
Dcur L - Bccur Bccur 0 Dcomp Dcomp
Dcur Dact Dact Dcur v?t
Y
ExceedAction
Dact gt Be
N
Y
Dcomp 0
Dcomp gt Be
N
38Shaping Configuration Sample
GTS Based
interface serial 2/1 ip unnumbered loopback
0 traffic-shape rate 64000 8000 1000
256 ! interface serial 2/2 ip unnumbered
loopback 0 traffic-shape group 100 64000 8000
8000 512 ! access-list 100 permit tcp host
10.0.0.1 any eq http
Shaper Definitions
ACL definition
Shaper can be only used to control egress traffic
flow!
39Policing Configuration Sample
IOS 12.0(5)T
CAR Based
ip cef interface serial 2/1 ip unnumbered
loopback 0 rate-limit output access-group 100
64000 8000 16000 conform-action transmit
excess-action drop ! interface serial 2/2 ip
unnumbered loopback 0 rate-limit input 128000
16000 32000 conform-action transmit
excess-action drop ! access-list 100 permit tcp
host 10.0.0.1 any eq http
CAR Definitions
ACL definition
Policer can be used to control ingress traffic
flow!
40Shaping/Policing Configuration Sample
IOS 12.1(5)T
MQI Based
class-map match-all policed match protocol
http class-map match-all shaped match
access-group name ftp-downloads ! policy-map
bad-boy class policed police 64000 8000 8000
conform-action transmit exceed-action drop
class shaped shape average 128000 ! interface
serial 2/1 ip unnumbered loopback
0 service-policy output bad-boy ! ip access-list
extended ftp-downloads permit tcp any eq
ftp-data any
Class definitions
QoS policy definition
QoS Policy attachedto interface
ACL definition
41CAR Policing Problem
- Why cannot my traffic reach CIR value?
- Cause Improper setting of Bc and Be values
- CAR is aggressive, as drops excessive packets
and the lost data needs to be retransmitted by
upper layers (mainly TCP) after timeout. This
also causes TCP to shrink its window reducing
flow throughput. - Cisco Systems recommends the following settings
- Bc 1.5xCIR/8
- Be 2xBc
42Congestion Management
43Queuing
- Traffic burst may temporarily exceed interface
capacity - Without queuing this excess traffic will be lost
- Queuing allows bursty traffic to be transmitted
without drops - Queuing strategy defines order in which packets
are transmitted through egress interface - Queuing introduced additional delay which signals
to adaptive flows (like TCP) to back off their
throughput
44Queuing Algorithms
- FIFO
- Priority (Absolute)
- Weighted Round Robin (WRR)
- Fair
45FIFO
- Simplest queuing method with the least CPU
overhead - No congestion control
- Transmits packets in the order of arrival
- High volume traffic can suppress interactive
flows - Default queuing for interfaces gt 2Mbps (i.e.
Ethernet)
46FIFO
FIFO average queue depth dependence on load
47Absolute Priority Queuing
- Generic Priority Queuing
- Custom Queuing
- RTP Priority Queuing
- Low Latency Queuing (LLQ)
48Simplest QoS Algorithm Priority Queuing
- Stated requirement
- If ltapplicationgt has traffic waiting, send it
next - Commonly implemented
- Defined behavior of IP precedence
49Priority Queuing Implementation Approach
- Identify interesting traffic
- Access lists
- Place traffic in various queues
- Dequeue in order of queue precedence
50Priority Queuing (PQ)
- Interface Hardware
- Ethernet
- Frame Relay
- ATM
- Serial Link
- Etc.
High
Traffic Destined for Interface
Medium
Classify
Normal
Transmit Queue
Output Line
Low
Q Length Defined by Q Limit
Absolute Priority Scheduling
Interface Buffer Resources
- Classification by
- Protocol (IP, IPX, AppleTalk, SNA, DecNet,
Bridge, etc.) - Incoming Interface (EO, SO, S1, etc.)
51Priority Queuing Scheme
Y
Y
Y
Y
High Empty?
Medium Empty?
Normal Empty?
Low Empty?
N
N
N
N
Send packet from High
Send Packet from Medium
Send Packet from Normal
Send Packet from Low
52Generic PQ Drawbacks
- Needs thorough admission control
- No upper limit for each priority level
- High risk of low priority queues starvation
effect
53Generic PQ Configuration Sample
priority-list 1 protocol ip high tcp
telnet priority-list 1 protocol ip high list
100 priority-list 1 protocol ip medium lt
1000 priority-list 1 interface ethernet 0/0
medium priority-list 1 default low ! interface
serial 2/1 ip unnumbered loopback
0 priority-group 1 ! access-list 100 permit tcp
host 10.0.0.1 any eq http
PQ Definition
PQ Attachedto Interface
ACL definition
54Custom Queuing (CQ) (Weighted Round Robin)
- Interface Hardware
- Ethernet
- Frame Relay
- ATM
- Serial Link
- Etc.
1/10
2/10
Traffic Destined for Interface
3/10
Transmit Queue
Output Line
2/10
Classify
3/10
Up to 16
Link Utilization Ratio
Weighted RoundRobin Scheduling (byte count)
Q Length Deferred by Queue Limit
Interface Buffer Resources
- Classification by
- Protocol (IP, IPX, AppleTalk, SNA, DecNet,
Bridge, etc.) - Incoming interface(EO, SO, S1, etc.)
Allocate Proportion of Link Bandwidth)
55WRR Drawbacks
- Unpredictable jitter
- Fairness significantly depends on MTU and TCP
window size - Complex calculations to achieve desired traffic
proportions
56CQ Byte-count Calculus
- Distribute bandwidth to 3 queues with proportion
xyz and packet sizes qx, qy, qz. - Calculate axx/qx, ayy/qy, azz/qz.
- Normalize and round ax, ay, az. ax
round(ax/min(ax, ay, az)) ay round(ay/min(ax,
ay, az)) az round(az/min(ax, ay, az)). - Convert obtained packet proportion into byte
count bcx axqx bcy ayqy bcz
azqz. - Actual bandwidth share of i-th queue can be
calculated with the following formula - For better approximation obtained byte-counts can
be multiplied by some positive whole number.
Starting with IOS 12.1 CQ employs Deficit Round
Robin algorithm and there is no need in such
byte-count tuning.
57CQ Configuration Sample
queue-list 1 protocol ip 1 tcp telnet queue-list
1 protocol ip 2 list 100 queue-list 1 protocol ip
3 udp 53 queue-list 1 interface ethernet 0/0
4 queue-list 1 queue 1 byte-count 3000 queue-list
1 queue 2 byte-count 4500 queue-list 1 queue 3
byte-count 3000 queue-list 1 queue 4 byte-count
1500 queue-list 1 default 4 ! interface serial
2/1 ip unnumbered loopback 0 custom-queue-list
1 ! access-list 100 permit tcp host 10.0.0.1 any
eq http
CQ List Definition
CQ Attachedto Interface
ACL Definition
58Bitwise Round Robin Fair Queuing
TDM Model
Time Division Multiplexer
- Keshav, Demers, Shenker, and Zhang
- Simulates a TDM
- One flow per channel
59TDM Message Arrival Sequence
6
4
1
5
2
Time Division Multiplexer
3
60TDM Message Delivery Sequence
5
4
1
6
3
Time Division Multiplexer
2
61Fair Queuing Algorithm
- Employs virtual bit-by-bit round robin model (BRR)
BRR dynamics are described by the equation
i-th packet from flow a arriving at time t0 is
services at time t
Servicing of i-th packet from flow a will start
at Sia and finish at Fia
Additional ? parameter is added for priority
assignment to inactive flows
Packets are ordered for transmission according to
Bia values.
62Fair Queuing Approach
- Enqueue traffic in the sequence the TDM would
deliver it - As a result, be as fair as the TDM
63Effects of Fair Queuing
- Low-bandwidth flows get
- As much bandwidth as they can use
- Timely service
- High-bandwidth flows
- Interleave traffic
- Cooperatively share bandwidth
- Absorb latency
64What Weighting Does
- In TDM
- Channel speed determines message duration
- In WFQ
- Multiplier on message length changes simulated
message duration - Result
- Flows fair share predictably unfair
65Weighted Fair Queuing (WFQ)
Traffic Destined for Interface
Transmit Queue
Output Line
Classify
Weighted Fair Scheduling
Configurable Number of Queues
Interface Buffer Resources
- Flow-Based Classification by
- Source and destination address
- Protocol
- Session identifier (port/socket)
- Weight Determined by
- Requested QoS (IP Procedure, RSVP)
- Frame Relay FECN, BECN, DE(For FR Traffic)
- Flow throughput (weighted-fair)
66Weighted Fair Queuing (WFQ)
- Fair bandwidth per flow allocation
- Low delay for interactive applications
- Protection from ill-behaved sources
67Weighted Fair Queuing (WFQ)
- Flow classified by the following fields
- Source address
- Source port
- Destination address
- Destination port
- ToS
- Weight of each flow (queue) depends on ToS
- weight 1/(precedence1)
- Bandwidth distributed in 1/weight proportions
68Weighted Fair Queuing (WFQ)
- Packets are ordered according to the expected
virtual departure time of their last bit. - Low volume flows have preference over high volume
transfers. - Low volume flow is identified as using less than
its share of bandwidth. - The special queue length threshold value is
established, after which only low volume flows
can enqueue. All the packets, that belong to high
volume flows are dropped.
69Drawbacks of Weighted Fair Queuing
- Requires more sorting than other approaches
70Weighted Fair Queuing (WFQ)
71Weighted Fair Queuing (WFQ)
72WFQ Configuration Sample
interface serial 2/1 ip unnumbered loopback
0 fair-queue 32 128 0
Queue Threshold (packets)
Number of reservable queues
Maximal numberof queues
73RTP Priority Queuing
- Classifies only by UDP port range
- Only even ports from the range are classified
- Establishes upper limit via integrated policer
- Excess traffic dropped during congestion periods
- RTP PQ has priority over LLQ
74RTP PQ Configuration Sample
interface serial 2/1 ip unnumbered loopback
0 ip rtp priority 16384 16383 256
Starting UDP port
Bandwidth Limit(kbps)
Range length
75Low Latency Queuing (LLQ)
- Implemented using MQI
- Very rich classification criteria (class-map)
- Establishes upper limit via integrated policer
- Excess traffic dropped during congestion periods
76LLQ Configuration Sample
IOS 12.0(5)T
class-map match-all voice match access-group
name voip ! policy-map llq class voip priority
30 class class-default fair-queue
64 ! interface serial 2/1 ip unnumbered loopback
0 service-policy output llq ! ip access-list
extended voip permit ip host 10.0.0.1 any
Class definitions
LLQ policy definition
LLQ Policy attachedto interface
ACL definition
77Class Based WFQ (CBWFQ)
- Based on the same algorithm as WFQ
- Weights can be manually configured
- Allows to easily specify guaranteed bandwidth for
a class - Configuration based on Cisco MQI
78CBWFQ Configuration Sample
IOS 12.0(5)T
class-map match-all premium match access-group
name premium-cust class-map match-all
low-priority match protocol napster ! policy-map
cbwfq-sample class premium bandwidth
512 class low-priority shape average
128 shape peak 512 class class-default fair-q
ueue 64 ! interface serial 2/1 ip unnumbered
loopback 0 max-reserved-bandwidth
85 service-policy output cbwfq-sample ! ip
access-list extended premium-cust permit ip host
10.0.0.1 any
Class definitions
Qos policy definition
QoS Policy attachedto interface
ACL definition
79CBWFQ Configuration Sample
IOS 12.1(5)T
Hierarchical Design
class-map match-all premium match access-group
name premium-cust class-map match-all
voice match ip precedence flash ! policy-map
total-shaper class class-default shape average
1536 service-policy class-policy policy-map
class-policy class premium bandwidth
512 class voice priority 64 class
class-default fair-queue 128
interface fastethernet 1/0 ip unnumbered
loopback 0 max-reserved-bandwidth
85 service-policy output total-shaper ! ip
access-list extended premium-cust permit ip host
10.0.0.1 any
80Hierarchical CBWFQ Limitations
- Only two levels of hierarchy are supported
- set command not supported in child policy
- Shaping allows only in parent policy
- LLQ can be configured only either in child or
parent policies but not in both - FQ allowed only in child policy
81Congestion Avoidance
82Global Synchronization Effect
83Tail Drop and TCP Flow Control
- Packet drops from all TCP sessions simultaneously
- High probability of multiple drops from the same
TCP session - Uniformly distributed drops from high volume and
interactive flows - Result Low average throughput!
84Random Early Detection (RED)
Developed by Van Jacobson in 1993
- Starts randomly dropping packets before actual
congestion occurs - Keeps average queue depth low
- Increases average throughput
85Global Synchronization Removed
86Random Early Detection (RED)
87Random Early Detection (RED)
RED Parameters
- ?min Minimal threshold after which RED starts
packet drops. Minimal recommended value is 5
packets. - ?max Maximal threshold after which all packets
are dropped. Recommended value is 2-3 times ?min. - ? - Mark probability denominator denotes packet
drop probability at ?max average queue depth.
Optimal value 0.1 . - ? - Exponential weighting factor determines the
level of backward value-dependence in average
queue depth calculation qavg (qold (1 -
2-?)) (qcur 2-?)General recommendation ? 9.
88TCP Rate Control - 1
- In TCP, the spacing of ACKs and the window size
in the ACKs controls the transmitters rate. - Rate Control manipulates the ACKs as they pass
through the rate control device by - Adjusting the size of TCP ACK window
- Inserting new ACKs
- Re-spacing existing ACKs
- Rate Control works only with TCP other methods,
such as Token Bucket, must be used with UDP. - Rate Control violates the protocol layering
design, as it allows network devices to
manipulate a higher-layer protocols operation.
Nevertheless, it usually functions well and
provides fine-grained control.
89TCP Rate Control - 2
90Weighted Random Early Detection (WRED)
- Modified version of RED
- Weights determine the set of parameters ?min ,
?max and ? . - Weight depends on ToS field value
- Interactive flows are preserved
91WRED Configuration Sample
Interface based
interface serial 2/1 ip unnumbered loopback
0 random-detect random-detect 0 32 64
20 random-detect 1 32 64 20 random-detect 2 32
64 20 random-detect 3 32 64 20
?min
?max
?
92WRED Configuration Sample
MQI based
policy-map red class class-default random-detec
t random-detect 0 32 64 20 random-detect 1 32
64 20 random-detect 2 32 64 20 random-detect
3 32 64 20 interface Serial2/1 ip unnumbered
loopback 0 service-policy output red
?min
?max
?
WRED is incompatible with LLQ feature!
93Link Optimization
94Link Fragmentation and Interleaving (LFI)
For links lt 128kbps
95Link Fragmentation and Interleaving (LFI)
- Supported interfaces
- Multilink PPP
- Frame Relay DLCI
- ATM VC
96LFI Configuration Sample
MLP version
interface virtual-template 1 ip unnumbered
loopback 0 ppp multilink ppp multilink
interleave ppp multilink fragment-delay 30 ip
rtp interleave 16384 1024 512
97Signaling
98Resource Reservation Protocol (RSVP)
- End-to-end QoS signaling protocol
- Used to establish dynamic reservations over the
network - Always establishes simplex reservation
- Supports unicast and multicast traffic
- Actually uses WFQ and WRED mechanisms
99Resource Reservation Protocol (RSVP)
100Resource Reservation Protocol (RSVP)
101Resource Reservation Protocol (RSVP)
- Reservation Types
- Guaranteed Rate (uses WFQ and LLQ)
- Controlled Load (uses WRED)
102Resource Reservation Protocol (RSVP)
103QoS Policy Propagation over BGP
- QoS policy can be shared inside single AS or
among different ASs. - Community attribute is usually used for color
assignments - Prevents manual policy changes in network devices
104QoS Policy Propagation over BGP
105QPPB Configuration Sample
Router A
Router B
ip bgp-community new-format ! router bgp 10
neighbor 10.0.0.1 remote-as 20 neighbor 10.0.0.1
send-community neighbor 10.0.0.1 route-map cout
out ! route-map cout permit 10 match ip address
20 set community 609 ! access-list 20 permit
192.168.0.0 0.0.0.255
ip bgp-community new-format ! router bgp 20
neighbor 10.0.0.2 remote-as 10 table-map
mark-pol ! route-map mark-pol permit 10 match
community 1 set ip precedence flash ! ip
community-list 1 permit 609 ! interface Serial
0/1 ip unnumbered loopback 0 bgp-policy source
ip-prec-map
106Topics not Covered
- Multiprotocol Label Switching (MPLS)
- Frame Relay QoS
- ATM QoS
- Distributed Queuing Algorithms
- Multicast
107Conclusion
- QoS is not an exotic feature any more
- QoS allows specific applications (VoIP, VC) to
share network infrastructure with best-effort
traffic - QoS in IP networks simplifies their functionality
avoiding Frame Relay and ATM usage
108?
Questions???