Title: OSPFv3
1OSPFv3
- CIS 185 Advanced Routing (CCNP 1)
- Spring 2006
- Rick Graziani
- Based on Chapter 4 Dynamic Routing Protocols,
Routing TCP/IP 2nd Edition, Jeff Doyle and
Jennifer Carroll
2OSPFv3 Introduction
- OSPFv2 could have been modified for IPv6 with new
or modified LSAs. - OSPFv2 developed in 1980s when
- router performance was low
- memory expensive
- IETF decided this was an opportunity to improve
the protocol itself.
3Operation of OSPFv3
- OSPFv3 specified in RFC 2740
- OSPFv3 uses same fundamental mechanisms as OSPFv2
including - SPF algorithm
- Flooding
- DR election
- Areas
- Timers
- Metrics
- Not backwards compatible with OSPFv2.
- If running both IPv4 and IPv6, must run both
OSPFv2 and OSPFv3 (discussions underway to add
IPv4 support to OSPv3). - Primary difference is with LSA formats.
4Differences between OSPFv2 and OSPFv3
- Per link processing
- IPv6 interfaces can have multiple
addresses/subnets - Two interfaces belonging to same link, but
different subnets can communicate. - Removal of addressing semantics
- Router LSAs and network LSAs do not carry IPv6
addresses, another LSA for this. - 32 bit Router-ID, Area-ID and LSA IDs still
maintained in OSPFv3, but are not IPv4 address in
OSPFv3 - Flooding Scope includes link local
- OSPFv3 retains flooding scope of routing domain
and areas. - OSPFv3 includes link-local flooding scope, for
information only relevant to neighbors on a
single link, not beyond any attached router.
5Differences between OSPFv2 and OSPFv3
- Use of link local addresses
- Similar to OSPFv2, OSPFv3 packets only has local
scope. - OSPFv3 uses a routers link local IPv6 addresses,
which begin with FF80/10. - Support for multiple instances per link
- Applications where multiple OSPF routers can be
attached to a single broadcast link but not form
an adjacency. - Example Network Access Point (NAP), where the
NAP Router A will form an adjacency with only
Company A router, and NAP Router B will form an
adjacency with only Company B router. - OPSFv3 allows for multiple instances per link.
- Can be done with OSPFv2 using authentication, but
this causes a lot of authentication failures.
6Differences between OSPFv2 and OSPFv3
- Removal of OSPF-specific authentication
- OSPFv3 uses IPv6 authentication extension header.
7OSPFv3 Messages
- OSPFv2 and OSPFv3 same protocol number of 89.
- Multicast Addresses
- IPv4
IPv6 - AllSPFRouters 224.0.0.5 FF025
- AllDRrouters 224.0.0.6
FF026 - OSPFv2 and OSPv3 same message types, with some
changes (wont go into detail here) - Hello
- Database Description
- Link State Request
- Link State Update
- Link State Acknowledgment
8Two renamed LSAs
- Interarea prefix LSAs for area border routers
(ABRs) (type 3) - Type 3 LSAs advertise internal networks to
routers in other areas (interarea routes). - Type 3 LSAs may represent a single network or a
set of networks summarized into one
advertisement. - Only ABRs generate summary LSAs.
- In OSPF for IPv6, addresses for these LSAs are
expressed as prefix, prefix length instead of
address, mask. - The default route is expressed as a prefix with
length 0.
9Two renamed LSAs
- Interarea router LSAs for autonomous system
boundary routers (ASBRs) (type 4) - Type 4 LSAs advertise the location of an ASBR.
- Routers that are trying to reach an external
network use these advertisements to determine the
best path to the next hop. - ASBRs generate type 4 LSAs.
10Two new LSAs
- Link LSAs (type 8)
- Information which is only significant to two
directly connected neighbors. - Type 8 LSAs have link-local flooding scope and
are never flooded beyond the link with which they
are associated. - Link LSAs provide the link-local address of the
router to all other routers attached to the link.
- Link LSAs also inform other routers attached to
the link of a list of IPv6 prefixes to associate
with the link, and allow the router to assert a
collection of options bits to associate with the
network LSA that will be originated for the link.
11Two new LSAs
- Intra-area prefix LSAs (type 9)
- Carries Prefixes for a referenced Link State ID.
- Prefix changes in OSPFv2 (sent in Router and
Network LSAs) causes an SPF recalculation), but
because they do not affect SPF tree, does not
cause SPF recalculation in OSPFv3. - Makes OSPFv3 more scalable for large networks
with large number of frequently changing prefixes.
12Configuring OSPFv3 Lab 8.1
13Objectives
- Configure a static IPv6 address on an interface
- Change the default-link local address on an
interface - Configure an EUI-64 IPv6 address on an interface
- Enable IPv6 routing and CEF
- Configure and verify single-area OSPFv3 operation
14Step 2 Configuring Loopback interfaces
R1(config) interface loopback0 R1(config-if) ip
address 10.1.1.1 255.255.255.0 R1(config-if)
ipv6 address FEC011/112
R2(config) interface loopback0 R2(config-if) ip
address 10.1.2.1 255.255.255.0 R2(config-if)
ipv6 address FEC021/112
R3(config) interface loopback0 R3(config-if) ip
address 10.1.3.1 255.255.255.0 R3(config-if)
ipv6 address FEC031/112 !Lab has typo here
- IPv6 addresses let you put in the mask length
with a /mask, rather than typing the whole mask
out in hexadecimal (imagine typing up to 128 bits
worth of 1s). - You also can put in the abbreviated form of an
IPv6 address. - You can abbreviate any continuous group of 0s
with . You can only use this abbreviation
once per address.
15Comparing IPv4 and IPv6 configuration
R1(config) interface loopback0 R1(config-if) ip
address 10.1.1.1 255.255.255.0 R1(config-if)
ipv6 address FEC011/112
- If you accidentally put the wrong IPv6 address on
an interface, make sure you take it off with the
no version of the command you entered. - Unlike IPv4 addresses, where the ip address
command overwrites the existing address, multiple
IPv6 addresses can exist on an interface. - Putting in the command ipv6 address multiple
times will add more addresses, not replace them. - Also, notice that we put both an IPv4 and IPv6
address on the same interface, and neither
conflict with each other. - This is because they are different layer 3
protocols and they run independently.
16Step 3 Configuring Static IPv6 Addresses
R1(config) interface serial0/0/0 R1(config-if)
ipv6 address FEC0121/112 R1(config-if)
clockrate 64000 R1(config-if) no
shutdown R1(config) interface s0/0/1 R1(config-if
) ipv6 address FEC0131/112 R1(config-if)
clockrate 64000 R1(config-if) no shutdown
R2(config) interface serial0/0/0 R2(config-if)
ipv6 address FEC0122/112 R2(config-if) no
shutdown
R3(config) interface serial0/0/0 R3(config-if)
ipv6 address FEC0133/112 R3(config-if)
clockrate 64000 R3(config-if) no shutdown
17Verifying Static IPv6 Addresses
R1ping FEC0122 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC0122, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
28/28/28 ms R1ping FEC0133 Type escape
sequence to abort. Sending 5, 100-byte ICMP Echos
to FEC0133, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip
min/avg/max 28/28/28 ms
R2ping FEC0121 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC0121, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
28/28/28 ms
R3ping FEC0131 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC0131, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
28/28/28 ms
18Step 4 Changing the Link-Local Address on an
Interface
R1show ipv6 interface ser 0/0/0 Serial0/0/0 is
up, line protocol is up IPv6 is enabled,
link-local address is FE8021BCFFFED089A8
Global unicast address(es) FEC0121,
subnet is FEC0120/112 ltoutput omittedgt
- Notice that in addition to the address you
already configured, there is a link local address
starting with FE80. - Your actual address may vary.
- There is no subnet mask on link-local addresses,
because they are not routed hence the term
link-local. - To configure this, use the command ipv6 address
address link-local.
19R2 Link-local Address
R2show ipv6 inter serial 0/0/0 Serial0/0/0 is
up, line protocol is up IPv6 is enabled,
link-local address is FE8021BCFFFED078E8
Global unicast address(es) FEC0122,
subnet is FEC0120/112 ltoutput omittedgt
- Notice that in addition to the address you
already configured, there is a link local address
starting with FE80.
20Configuring Link-local Address
R1(config) interface serial0/0/0 R1(config-if)
ipv6 address FE801 link-local
R2(config) interface serial0/0/0 R2(config-if)
ipv6 address FE802 link-local
- You can change this on the link between R1 and R2
by putting the link-local address FE801 on R1
and FE802 on R2.
21Verifying Link-local address
R1ping FE802 Output Interface
Serial0/0/0 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to FE802,
timeout is 2 seconds Packet sent with a source
address of FE801 !!!!! Success rate is 100
percent (5/5), round-trip min/avg/max 28/28/28
ms
R2ping FE801 Output Interface
Serial0/0/0 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to FE801,
timeout is 2 seconds Packet sent with a source
address of FE802 !!!!! Success rate is 100
percent (5/5), round-trip min/avg/max 28/28/28
ms
- Verify that you can ping the link local address
on the other side. - When pinging link local addresses, you must
specify an outgoing interface because the
addresses are not routed and not in the routing
table.
22Verifying new addresses
R1show ipv6 interface serial 0/0/0 Serial0/0/0
is up, line protocol is up IPv6 is enabled,
link-local address is FE801 ltoutput omittedgt
R2show ipv6 interface serial 0/0/0 Serial0/0/0
is up, line protocol is up IPv6 is enabled,
link-local address is FE802 ltoutput omittedgt
23Step 5 Configuring EUI-64 Addresses
R2(config) interface fastethernet0/0 R2(config-if
) ipv6 address FEC023/64 eui-64 R2(config-if)
no shutdown
R3(config) interface fastethernet0/0 R3(config-if
) ipv6 address FEC023/64 eui-64 R3(config-if)
no shutdown
- EUI-64 IPv6 addresses are addresses where the
first 64 bits are the network portion of the
address and specified, and the second 64 bits are
the host portion of the address and automatically
generated by the device. - Configure this on the FastEthernet interfaces of
R2 and R3 with the subnet given in the diagram. - Also, make sure you put a no shutdown on the
interfaces.
24EUI-64 Addresses
R2show ipv6 inter brief FastEthernet0/0
up/up FE8021BCFFFED078E8
FEC02321BCFFFED078E8
R2show inter fa 0/0 FastEthernet0/0 is up, line
protocol is up Hardware is MV96340 Ethernet,
address is 001b.0cd0.78e8 ltoutput omittedgt
- EUI-64 mechanism
- takes the 48-bit Media Access Control (MAC)
address of the interfacewhich can normally be
assumed to be globally unique - converts it into a 64-bit Interface ID by
inserting a reserved 16-bit value of 0xFFFE into
the middle of the MAC address - "flipping" the Universal/Local (U/L) bit of the
MAC address to 1 (Universal).
25Verifying EUI-64 Addresses
R2ping fec02321bcfffec284a0 Type escape
sequence to abort. Sending 5, 100-byte ICMP Echos
to FEC02321BCFFFEC284A0, timeout is 2
seconds !!!!! Success rate is 100 percent (5/5),
round-trip min/avg/max 0/0/4 ms
26Step 6 Enabling IPv6 Routing and CEF
R1(config) ipv6 unicast-routing R1(config) ipv6
cef
R2(config) ipv6 unicast-routing R2(config) ipv6
cef
R3(config) ipv6 unicast-routing R3(config) ipv6
cef
- As of the time of this writing, the current IOS
version has IPv6 routing and CEF disabled by
default. - To enable IPv6 routing, use the global
configuration command ipv6 unicast-routing. - To enable IPv6 CEF, use the command ipv6 cef.
27Step 7 Setting up OSPv3
R1(config)interface loopback0 R1(config-if)ipv6
ospf 1 area 0 R1(config)interface
serial0/0/0 R1(config-if)ipv6 ospf 1 area
0 R1(config)interface serial0/0/1 R1(config-if)
ipv6 ospf 1 area 0
OSPFv3 is configured on the interface instead of
the network command in OSPFv2. Allows for more
control over which interfaces are enabled for
OSPF without the use of wildcard masks.
- Once you add the interfaces to the OSPF process
with this command, the OSPF process will start
automatically. - If the adjacencies dont come up after a
reasonable period of time, troubleshoot usingthe
debug commands debug ipv6 ospf adjacency and
debug ipv6 packet.
28Configuring R2 and R3
R2(config)interface loopback0 R2(config-if)ipv6
ospf 1 area 0 R2(config)interface
serial0/0/0 R2(config-if)ipv6 ospf 1 area
0 R2(config)interface fastethernet0/0 R2(config-
if)ipv6 ospf 1 area 0
R3(config)interface loopback0 R3(config-if)ipv6
ospf 1 area 0 R3(config-if)interface
serial0/0/0 R3(config-if)ipv6 ospf 1 area
0 R3(config-if)interface fastethernet0/0 R3(conf
ig-if)ipv6 ospf 1 area 0
29Verify OSPFv3 Neighbors
R1show ipv6 ospf neighbor Neighbor ID Pri
State Dead Time Interface ID
Interface 10.1.3.1 1 FULL/ - 000039
6 Serial0/0/1 10.1.2.1 1 FULL/
- 000034 6 Serial0/0/0
- R2show ipv6 ospf neighbor
- Neighbor ID Pri State Dead Time
Interface ID Interface - 10.1.3.1 1 FULL/DR 000039 4
FastEthernet0/0 - 10.1.1.1 1 FULL/ - 000032 6
Serial0/0/0
- R3show ipv6 ospf neighbor
- Neighbor ID Pri State Dead Time
Interface ID Interface - 10.1.2.1 1 FULL/BDR 000039 4
FastEthernet0/0 - 10.1.1.1 1 FULL/ - 000039 7
Serial0/0/0
- The router IDs for each router are created the
same way that they are in OSPFv2. - Without any IPv4 addresses on the router, the
OSPFv3 process will not start unless you manually
set the router IDs. - This is why the loopback interfaces have both
IPv4 and IPv6 addresses.
30Verifying with show ipv6 route
R2show ipv6 route IPv6 Routing Table - 11
entries Codes C - Connected, L - Local, S -
Static, R - RIP, B - BGP U - Per-user
Static route I1 - ISIS L1, I2 - ISIS L2,
IA - ISIS interarea, IS - ISIS summary O -
OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1,
OE2 - OSPF ext 2 ON1 - OSPF NSSA ext 1,
ON2 - OSPF NSSA ext 2 L FE80/10 0/0
via , Null0 O FEC011/128 110/64 via
FE801, Serial0/0/0 C FEC020/112 0/0
via , Loopback0 L FEC021/128 0/0
via , Loopback0 O FEC031/128 110/1
via FE8021BCFFFEC284A0, FastEthernet0/0 C
FEC0120/112 0/0 via , Serial0/0/0 L
FEC0122/128 0/0 via , Serial0/0/0 O
FEC0130/112 110/65 via
FE8021BCFFFEC284A0, FastEthernet0/0 C
FEC023/64 0/0 via , FastEthernet0/0 L
FEC02321BCFFFED078E8/128 0/0 via
, FastEthernet0/0 L FF00/8 0/0 via
, Null0
31R2show ipv6 ospf interface FastEthernet0/0 is
up, line protocol is up Link Local Address
FE8021BCFFFED078E8, Interface ID 4 Area 0,
Process ID 1, Instance ID 0, Router ID 10.1.2.1
Network Type BROADCAST, Cost 1 Transmit Delay
is 1 sec, State DR, Priority 1 Designated
Router (ID) 10.1.2.1, local address
FE8021BCFFFED078E8 Backup Designated
router (ID) 10.1.3.1, local address
FE8021BCFFFEC284A0 Timer intervals
configured, Hello 10, Dead 40, Wait 40,
Retransmit 5 Hello due in 000000 Index
1/3/3, flood queue length 0 Next
0x0(0)/0x0(0)/0x0(0) Last flood scan length is
1, maximum is 4 Last flood scan time is 0 msec,
maximum is 0 msec Neighbor Count is 1, Adjacent
neighbor count is 1 Adjacent with neighbor
10.1.3.1 (Backup Designated Router) Suppress
hello for 0 neighbor(s) Serial0/0/0 is up, line
protocol is up Link Local Address FE802,
Interface ID 6 Area 0, Process ID 1, Instance
ID 0, Router ID 10.1.2.1 Network Type
POINT_TO_POINT, Cost 64 Transmit Delay is 1
sec, State POINT_TO_POINT, Timer intervals
configured, Hello 10, Dead 40, Wait 40,
Retransmit 5 Hello due in 000003 Index
1/2/2, flood queue length 0 Next
0x0(0)/0x0(0)/0x0(0) Last flood scan length is
1, maximum is 4 Last flood scan time is 0 msec,
maximum is 0 msec Neighbor Count is 1, Adjacent
neighbor count is 1 Adjacent with neighbor
10.1.1.1 Suppress hello for 0
neighbor(s) Loopback0 is up, line protocol is up
Link Local Address FE8021BCFFFED078E8,
Interface ID 13 Area 0, Process ID 1, Instance
ID 0, Router ID 10.1.2.1 Network Type LOOPBACK,
Cost 1 Loopback interface is treated as a stub
Host
32Verify Ping Global Addresses
R1ping fec031 !Loopback on R3 Type escape
sequence to abort. Sending 5, 100-byte ICMP Echos
to FEC031, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
28/28/28 ms R1ping fec02321bcfffec284a0
!FastEthernet on R3 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC02321BCFFFEC284A0, timeout is 2
seconds !!!!! Success rate is 100 percent (5/5),
round-trip min/avg/max 28/28/28 ms R1
33Can only ping local link-local interfaces
R1ping fe8021bcfffec284a0 !Link-local
interface on R2s Ethernet link Output Interface
serial0/0/0 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FE8021BCFFFEC284A0, timeout is 2
seconds Packet sent with a source address of
FE801 ...T. Success rate is 0 percent
(0/5) R1ping fe8021bcfffec284a0
!Link-local on interface on R3s serial link with
R1 Output Interface serial0/0/1 Type escape
sequence to abort. Sending 5, 100-byte ICMP Echos
to FE8021BCFFFEC284A0, timeout is 2
seconds Packet sent with a source address of
FE8021BCFFFED089A8 !!!!! Success rate is 100
percent (5/5), round-trip min/avg/max 28/28/28
ms R1
34Summarization
R2(config)inter loop 100 R2(config-if)ipv6 add
fec05001001/112 R2(config-if)ipv6 ospf 1
area 500 R2(config)inter loop 200 R2(config-if)i
pv6 add fec05002001/112 R2(config-if)ipv6
ospf 1 area 500 R2(config)ipv6 router
ospf 1 !First time needed to use router
mode R2(config-rtr)area 500 range fec0500/64
- The commands available for OSPFv3 are very close
to the commands available for OSPFv2. - On R2, add in two loopback interfaces, with the
addresses FEC05001001 /112 and
FEC05002001 /112. - Add both of these interfaces to the OSPF process
in area 500. - Summarize area 500 to FEC0500 /64.
- To enter the OSPF configuration prompt, use the
command ipv6 router ospf process. - Once in the prompt, use the area range command to
summarize the address.
35Verify Summarization
R3show ipv6 route ltoutput omittedgt OI
FEC0500/64 110/1 via FE8021BCFFFED0
78E8, FastEthernet0/0
36Lab 8.2 Using Manual IPv6 Tunnels
37Objectives
- Configure EIGRP for IPv4
- Create a manual IPv6 tunnel
- Configure OSPFv3
38Step 2 Configure Interfaces (Loopback serial)
R1(config) interface loopback0 R1(config-if) ip
address 10.1.1.1 255.255.255.0 R1(config-if)
ipv6 address FEC011/112 R1(config) interface
serial0/0/0 R1(config-if) ip address 172.16.12.1
255.255.255.0 R1(config-if) clockrate
64000 R1(config-if) no shutdown
39R2s Configuration All IPv4
R2(config) interface loopback0 R2(config-if) ip
address 10.1.2.1 255.255.255.0 R2(config)
interface serial0/0/0 R2(config-if) ip address
172.16.12.2 255.255.255.0 R2(config-if) no
shutdown R2(config) interface
serial0/0/1 R2(config-if) ip address 172.16.23.2
255.255.255.0 R2(config-if) clockrate
64000 R2(config-if) no shutdown
40R3s Configuration
R3(config) interface loopback0 R3(config-if) ip
address 10.1.3.1 255.255.255.0 R3(config-if)
ipv6 address FEC031/112 R3(config) interface
serial0/0/1 R3(config-if) ip address 172.16.23.3
255.255.255.0 R3(config-if) no shutdown
41Step 3 Configure EIGRP
R1(config) router eigrp 1 R1(config-router) no
auto-summary R1(config-router) network
10.0.0.0 R1(config-router) network 172.16.0.0
R2(config) router eigrp 1 R2(config-router) no
auto-summary R2(config-router) network
10.0.0.0 R2(config-router) network 172.16.0.0
R3(config) router eigrp 1 R3(config-router) no
auto-summary R3(config-router) network
10.0.0.0 R3(config-router) network 172.16.0.0
42Verify show ip route
R1show ip route 172.16.0.0/24 is subnetted,
2 subnets D 172.16.23.0 90/2681856 via
172.16.12.2, 000104, Serial0/0/0 C
172.16.12.0 is directly connected, Serial0/0/0
10.0.0.0/24 is subnetted, 3 subnets D
10.1.3.0 90/2809856 via 172.16.12.2, 000030,
Serial0/0/0 D 10.1.2.0 90/2297856 via
172.16.12.2, 000104, Serial0/0/0 C
10.1.1.0 is directly connected, Loopback0
R2show ip route 172.16.0.0/24 is subnetted,
2 subnets C 172.16.23.0 is directly
connected, Serial0/0/1 C 172.16.12.0 is
directly connected, Serial0/0/0 10.0.0.0/24
is subnetted, 3 subnets D 10.1.3.0
90/2297856 via 172.16.23.3, 000036,
Serial0/0/1 C 10.1.2.0 is directly
connected, Loopback0 D 10.1.1.0
90/2297856 via 172.16.12.1, 000110,
Serial0/0/0
R3show ip route 172.16.0.0/24 is subnetted,
2 subnets C 172.16.23.0 is directly
connected, Serial0/0/1 D 172.16.12.0
90/2681856 via 172.16.23.2, 000011,
Serial0/0/1 10.0.0.0/24 is subnetted, 3
subnets C 10.1.3.0 is directly connected,
Loopback0 D 10.1.2.0 90/2297856 via
172.16.23.2, 000011, Serial0/0/1 D
10.1.1.0 90/2809856 via 172.16.23.2, 000011,
Serial0/0/1
43Configure a Manual IPv6 Tunnel
R1(config) int tunnel0 R1(config-if) tunnel
mode ipv6ip R1(config-if) tunnel source
s0/0/0 R1(config-if) tunnel destination
172.16.23.3 (??? IPv4 ??) R1(config-if) ipv6
add FEC0131/112 (Local IPv6 ??)
R3(config) int tunnel0 R3(config-if) tunnel
mode ipv6ip R3(config-if) tunnel source
s0/0/1 R3(config-if) tunnel destination
172.16.12.1 R3(config-if) ipv6 add FEC0133/112
- IP v6? IPv4 ?? ???
- To configure a manual IPv6 tunnel, first issue
the interface tunnel number command. - For simplicity, use tunnel number 0 on both
routers.
44R1(config) int tunnel0 R1(config-if) tunnel
mode ipv6ip R1(config-if) tunnel source
s0/0/0 R1(config-if) tunnel destination
172.16.23.3 R1(config-if) ipv6 add
FEC0131/112
R3(config) int tunnel0 R3(config-if) tunnel
mode ipv6ip R3(config-if) tunnel source
s0/0/1 R3(config-if) tunnel destination
172.16.12.1 R3(config-if) ipv6 add FEC0133/112
45R1ping FEC0133 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC0133, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
64/66/68 ms
R3ping FEC0131 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC0131, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
64/66/68 ms
46Step 5 Configure OSPFv3 over a Tunnel
R1(config) ipv6 unicast-routing R1(config)
interface loopback 0 R1(config-if) ipv6 ospf 1
area 0 R1(config) interface tunnel
0 R1(config-if) ipv6 ospf 1 area 0
R3(config) ipv6 unicast-routing R3(config)
interface loopback 0 R3(config-if) ipv6 ospf 1
area 0 R3(config) interface tunnel
0 R3(config-if) ipv6 ospf 1 area 0
- Enable IPv6 routing with the ipv6 unicast-routing
command on R1 and R3. - Configure OSPFv3 on those routers to run over the
tunnel and advertise the loopback interfaces into
OSPFv3.
47OSPF over IPv6 Tunnel
R1(config) ipv6 unicast-routing R1(config)
interface loopback 0 R1(config-if) ipv6 ospf 1
area 0 R1(config) interface tunnel
0 R1(config-if) ipv6 ospf 1 area 0
R3(config) ipv6 unicast-routing R3(config)
interface loopback 0 R3(config-if) ipv6 ospf 1
area 0 R3(config) interface tunnel
0 R3(config-if) ipv6 ospf 1 area 0
48Verify Tunnel
OSPF over IPv6 Tunnel
R1show ipv6 ospf neighbor Neighbor ID Pri
State Dead Time Interface ID
Interface 10.1.3.1 1 FULL/ -
000039 18 Tunnel0 R1
R3show ipv6 ospf neigh Neighbor ID Pri
State Dead Time Interface ID
Interface 10.1.1.1 1 FULL/ -
000033 14 Tunnel0 R3
49Verify Tunnel
OSPF over IPv6 Tunnel
R1ping FEC031 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC031, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
64/64/68 ms
R3ping FEC011 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC011, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
64/66/68 ms
50Lab 8.3 Configuring 6to4 Tunnels
51R1(config) interface tunnel 0 R1(config-if)
tunnel mode ipv6ip 6to4 R1(config-if) ipv6
address 2002AC100C0111/64 R1(config-if)
tunnel source serial0/0/0 R1(config-if)
exit R1(config) ipv6 route 2002/16 tunnel0
R3(config) interface tunnel 0 R3(config-if)
tunnel mode ipv6ip 6to4 R3(config-if) ipv6
address 2002AC10170313/64 R3(config-if)
tunnel source serial0/0/1 R3(config-if)
exit R3(config) ipv6 route 2002/16 tunnel0
52R1(config) interface tunnel 0 R1(config-if)
tunnel mode ipv6ip 6to4 R1(config-if) ipv6
address 2002AC100C0111/64 R1(config-if)
tunnel source serial0/0/0 R1(config-if)
exit R1(config) ipv6 route 2002/16 tunnel0
R3(config) interface tunnel 0 R3(config-if)
tunnel mode ipv6ip 6to4 R3(config-if) ipv6
address 2002AC10170313/64 R3(config-if)
tunnel source serial0/0/1 R3(config-if)
exit R3(config) ipv6 route 2002/16 tunnel0
- A 6to4 tunnel uses special IPv6 addresses in the
2002/16 address space. - The first 16 bits are the hexadecimal number
2002, and the next 32 bits are the original
source IPv4 address in hexadecimal form. - A 6to4 tunnel does not require a destination
address because it is not a point-to-point link.
53R1(config) interface tunnel 0 R1(config-if)
ipv6 address 2002AC100C0111/64
- The address for R1 is 2002AC100C0111/64,
because AC100C01 corresponds to 172.16.12.1 - 172 being AC,
- 16 being 10
- 12 being C
- 1 being 1
- The 1 after this address is just a more specific
subnet, and the 1 at the end is the host address.
- R3s address is 2002AC10170313/64.
- Notice that the two addresses are not in the same
/64 subnet.
54Verify Tunnel
R1ping 2002AC10170313 Type escape sequence
to abort. Sending 5, 100-byte ICMP Echos to
2002AC10170313, timeout is 2
seconds !!!!! Success rate is 100 percent (5/5),
round-trip min/avg/max 64/67/68 ms
R3ping 2002AC10C0111 Type escape sequence
to abort. Sending 5, 100-byte ICMP Echos to
2002AC10C0111, timeout is 2
seconds !!!!! Success rate is 100 percent (5/5),
round-trip min/avg/max 64/66/68 ms
55Step 5 Configure Static IPv6 Routes
- Just like IPv4, IPv6 can have static routes
entered into its routing table. - You already created one for the 2002/16 network
in Step 4. - For this section of the lab, you will put a
static route on R1 telling it how to get to R3s
loopback address. - On R3, you will put a static default route
pointing to R1. - Just like in IPv4, static routes with a next-hop
IPv6 address are created with the ipv6 route
address/mask next-hop command. - The next hop for both routers is the IPv6 address
of the other end of the tunnel. - Before entering these commands, enable IPv6
routing with the ipv6 unicast-routing command. - You can verify by using the show ipv6 route
command or by pinging the remote loopback address
from each router.
56Configure Static Routes
R1(config) ipv6 unicast-routing R1(config) ipv6
route FEC030/112 2002AC10170313
R3(config)ipv6 unicast-routing R3(config)ipv6
route /0 2002ac10c0111 !Not done in lab
57Configure Static Routes
R1ping FEC031 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC031, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
64/67/68 ms
R3ping FEC011 Type escape sequence to
abort. Sending 5, 100-byte ICMP Echos to
FEC011, timeout is 2 seconds !!!!! Success
rate is 100 percent (5/5), round-trip min/avg/max
64/66/68 ms
58Verify Static Routes
R1(config) ipv6 unicast-routing R1(config) ipv6
route FEC030/112 2002AC10170313 R1(config)
ipv6 route 2002/16 tunnel0
R3(config) ipv6 unicast-routing R3(config) ipv6
route /0 2002ac10c0111 R3(config) ipv6
route 2002/16 tunnel0
R1show ipv6 route S 2002/16 1/0 via
, Tunnel0 S FEC030/112 1/0 via
2002AC10170313 ltoutput omittedgt R1
R3show ipv6 route S 2002/16 1/0 via
, Tunnel0 S /0 1/0 via
2002AC10C0111 ltoutput omittedgt R3
59OSPFv3
- CIS 185 Advanced Routing (CCNP 1)
- Spring 2006
- Rick Graziani
- Based on Chapter 4 Dynamic Routing Protocols,
Routing TCP/IP 2nd Edition, Jeff Doyle and
Jennifer Carroll